PhotoSmash Galleries Plugin turns 1,000

picture-5Even as I sit here trying to fix a thorny problem with PhotoSmash, I popped by the plugin’s page and noticed that it had turned 1,000 downloads on the nose. Let’s hope the next 1,000 downloads have it a bit easier. PhotoSmash is a WordPress photo gallery plugin lets you let your visitors upload images into galleries right inside your posts. It’s sort of a unique feature amongst galleries today, but I’m sure there will be some other excellent implementations on the same theme down the road. Anyway, thanks to all you who’ve tried PhotoSmash. You’re helping me make it better.

Cheers to you!

Byron

,

42 Responses to PhotoSmash Galleries Plugin turns 1,000

  1. Mark de Scande February 28, 2009 at 4:46 am #

    1 I want to start using you plug on WP Mu do you think it is a good idea.

    2 I am using it on http://www.victoriaparkhigh.com it is working ok but i need to have 3 images next to each outher is there a way to do this or is it all size dependent 125X125px

    Thx

    Mark

  2. Byron Bennett February 28, 2009 at 1:33 pm #

    Hi Mark,

    I really don’t know if it will work with MU.

    I will put some code in it (at some point here) to give you an option to specify the # of images per row. Right now, it all depends on size and any padding/margins you put in the CSS. You could play around with padding and margins in the CSS on the img tag within the gallery div.

    BB

  3. zac March 8, 2009 at 10:32 pm #

    I am using it with MU and it works in Firefox.. not IE 7 though (I think I forgot to mention I was on MU in my other post)

  4. Jonathan March 24, 2009 at 7:00 am #

    Hi Byron,

    This is just the sort of plugin I have been looking for. The only problem I have found is with the theme I am using it causes problems. The Theme is fusion.

    The problems are the link to the sub-pages do not appear, and the filled area around the buttons changes to a light grey instead of blending in.

    I look forward to using it when these problems are sorted or I work out how to get round them.

  5. Briana March 25, 2009 at 9:19 pm #

    This is exactly the kind of plugin I have been looking for, unfortunately, it is not working for me. It takes me through the motions of uploading an image to the gallery, and it looks like it is there on the page, but then it disappears. I would be very thankful for any support in making it work. Thank you.

  6. Byron Bennett March 25, 2009 at 9:34 pm #

    Briana,
    Could be that the images were uploaded while you weren’t logged in. This would put them in moderation and they would only be visible to an Admin. The Admin could approve them and they would be visible to anyone.

    The fact that you can see the images on the page leads me to believe that they’re uploaded ok.

    Let me know if that doesn’t help.

    Byron

  7. Byron Bennett March 25, 2009 at 9:41 pm #

    Jonathan,
    You can probably fix that by tweaking the bwbps.css file. If you do, make sure you save off a copy that you can put back in any time you upgrade to a later version of the plugin.

    Look for CSS rules having this class: .bwbps_pagination

    You can play around with the background-color and the color (which is the font color) to see what works best with your theme.

    Cheers,
    Byron

  8. Briana March 25, 2009 at 9:58 pm #

    I was logged in. When I went to the admin area, it said no images, and when I reload the page with the gallery, there is nothing there, but if I try to upload again, it has the same image ready to be uploaded. I’m using a theme called Aspire, if that might have anything to do with it.
    Thank you for the quick help. I would really love to be able to use this, since it’s the only one I’ve seen that suits my needs.

  9. Briana March 25, 2009 at 10:00 pm #

    BTW, does it matter that it’s on a Page and not a Post?

  10. Byron Bennett March 25, 2009 at 10:21 pm #

    Hi Briana,

    So when you upload, you don’t see the thumbnail pop up on your screen when it’s done?

    Page or Post should not matter.

    Do you have a test site I could take a look at? There have been a few other folks having trouble also, but I can’t reproduce the problem on my sites.

    Cheers,
    Byron

  11. Briana March 26, 2009 at 4:18 pm #

    Yes, after I upload, I see the thumbnail in the gallery, I can even click on it. But when I get back to the page it is gone, and there is nothing in the admin.
    I don’t have a test site, only my live site, thevampireslair.com . I have it on a page called Pic of the Day. I have turned it off right now, but I could re-enable it. I was hoping for a fix before I made it live to the public again.

  12. Briana March 26, 2009 at 4:38 pm #

    I took a look on my server, and oddly enough, it is uploading the images and creating the thumbnails in the right place, even though they are invisible in the admin and the gallery itself. I even set it so that anyone could upload and there had to be moderation. Didn’t work.
    Do you think the problem has anything to do with the fact that I have multiple installations, and the prefixes are different? Each of my blogs is different, like: wp_mine, wp_vampire, etc, rather than the general wp_

  13. Byron Bennett March 26, 2009 at 7:47 pm #

    Briana,

    I was able to upload too…it all looks good there, but I’m betting that for some reason it’s not saving to the database.

    Could you take a look in your blog’s database and see if you see a the tables like… wp_prefix + bwbps_images ? If so, check to see if they have any entries…I’m guessing not, but maybe they do. I’ll start checking my code to see if I’ve missed using the database prefix variable somewhere.

    The good news is that the upload is occuring just fine…that’s been the biggest issues so far. We should be able to squash a database bug! 😉

    Cheers,
    Byron

  14. Byron Bennett March 26, 2009 at 8:02 pm #

    Briana,
    I checked the database code, and it should be using whatever Prefix you set as $table_prefix in your wp-config.php file.

    Let me know whether you see the 2 tables:

    prefix + bwbps_images
    prefix + bwbps_galleries

    Also, what is the prefix on those?

    If all that looks good, what version of MySQL are you running?

    I may have been over optimistic in my last comment….I’m running out of ideas on this one!

    BB

  15. Fernando April 21, 2009 at 9:20 am #

    Hello

    I love your plugin
    and would like a help!
    could the user to upload and post the picture is not entirely unique, in the gallery?

    as this example
    http://www.worth1000.com/contest.asp?contest_id=23099&display=photoshop

    or this example that the real
    http://desafiospsbrasil.wordpress.com/2009/04/17/33%C2%BA-desafio-iniciante/

    and other questions, you can remove the black background?

  16. Byron Bennett April 21, 2009 at 10:35 am #

    Hi Fernando,

    Thanks for trying out PhotoSmash!

    I’m not sure I understand your first question. There is no way to tell if the image is going to be unique when the user uploads the image. PhotoSmash lets you upload duplicate images and can’t really stop that.

    As to the 2nd: Yes, you can control the background color. Look for the file bwbps.css in the plugin folder and edit it.

    Look for the following code:

    .bwbps_gallery_div{
    background:#222;

    change it to

    .bwbps_gallery_div{
    background:#fff;

    If you use #fff; that will give you a white background. You can set it to any color you like.

    Cheers,
    Byron

  17. TJ May 20, 2009 at 1:20 am #

    I am also having the same problem as Brianna.

  18. TJ May 20, 2009 at 1:25 am #

    Operating System : Linux
    Server : Apache/2.2.11 (Unix) mod_ssl/2.2.11 OpenSSL/0.9.8b mod_bwlimited/1.4
    Memory usage : 13.16 MByte
    MYSQL Version : 5.0.67-community
    SQL Mode : Not set
    PHP Version : 5.2.9
    PHP Safe Mode : Off
    PHP Allow URL fopen : On
    PHP Memory Limit : 150M
    PHP Max Upload Size : 130M
    PHP Max Post Size : 150M
    PHP Max Script Execute Time : 30s
    PHP Exif support : No
    PHP IPTC support : Yes
    PHP XML support : Yes

  19. chris leslie May 25, 2009 at 2:47 pm #

    Hi Byron

    Im have installed the plug in Ok and its uploading images ok, just wanted to know how to sort it so as an administator I get an email message about the new imagery so I can moderate it….

    do you have any additional info on this?

    thanks for your time and the plug in!

    chris

  20. chris leslie May 25, 2009 at 2:47 pm #

    Hi Byron

    Im have installed the plug in Ok and its uploading images ok, just wanted to know how to sort it so as an administator I get an email message about the new imagery so I can moderate it….

    do you have any additional info on this?

    thanks for your time and the plug in!

    chris

  21. Byron Bennett May 25, 2009 at 6:23 pm #

    Hi Chris,

    You’re welcome. The moderation emails should go to the Admin email address. There are options in the PhotoSmash Settings page for how frequently emails are sent…10 minutes, 1 hour, once a day. I really need to add a “Send immediately” setting. I didn’t want people to be overwhelmed with emails, but that really is a bit of excessive optimism, isn’t it?

    So, I will add that setting in the near future.

    The current feature simulates Cron by checking the timing whenever a gallery is visited. So, if you choose 10 minutes and then visit a PS gallery 10 minutes after the upload, it should fire the email.

    Hope that helps,
    Byron

  22. TJ May 25, 2009 at 11:07 pm #

    Any support for the image disappearing problem?

  23. Byron Bennett May 25, 2009 at 11:21 pm #

    Hi TJ,

    Sorry about not getting back to you sooner! I dropped the ball.

    We eventually got Briana working. I don’t remember exactly what the issue was. We concluded that issue over email.

    Basically, if you’re seeing images after upload, then the upload is going ok, it’s processing the Thumbnails, but it’s not saving to the database.

    Before we get too invasive, here are the 1st two steps that have helped other folks:

    1) There is now a button in the Plugin Info page of Admin to ‘Update Database’. Go ahead and run that, even though everything may be showing green. The status checker doesn’t check field level, just table level.

    2) Re-upload the plugin using an FTP client. This has been a issue with several folks in the past, so it’s just one to check of the list of things we tried.

    If those don’t work, let me know. You can email me at byron @ whypad.com. I’ll be glad to do whatever I can to get you up and running.

    Again, sorry for dropping the ball.
    Byron

  24. PB May 28, 2009 at 10:37 am #

    I am also having the same problem as Brianna.

  25. Byron Bennett May 28, 2009 at 8:32 pm #

    Hi PB,

    I was able to help TJ (and Brianna). Just got TJ running today. It turns out there was a conflict with one of the plugins he had running, so I gave him a little modification that seems to working as expected now.

    If you’ve already tried the suggestions in my response to TJ, the next thing I’d recommend is to try the Development version of PhotoSmash. I know that the problem TJ had was solved in the Development version. See the “Beta Testers” section at the top of the main PhotoSmash Post. It gives you details on getting a copy of the Dev version from WordPress. You’ll need to Deactivate PhotoSmash before you upload the new version, and Reactivate it after it’s uploaded.

    If you try that and it’s still not working, let me know and I’ll dive deeper.

    Byron

  26. TJ May 28, 2009 at 11:18 pm #

    Kudos to Byron for getting me all up and running!

  27. EcoSee June 4, 2009 at 10:05 am #

    I love the plugin. I have integrated into my site to start a photo contest. But, people keep uploading huge images and then the whole thing falls apart. I have tried to find a way to force the image width but so far I just can’t make it happen and in the meantime… users just keep uploading these huge images. Sure wish I could find a solution to this.

  28. Byron Bennett June 4, 2009 at 10:57 am #

    Hi EcoSee,

    Glad you’re enjoying the plugin! The feature you’re looking for is built into the next version. Take a look at the main plugin page. That version is available for download now. The main plugin page describes how to get that.

    If you do decide to upgrade before it is officially released, be sure to go into the Plugin Info page and run the Update DB button.

    Gotta run right now, so sorry to cut it short. Let me know if you have questions.

    BB

  29. Plymouth RC Racing July 4, 2009 at 4:14 am #

    Hi,

    I think this is a great plugin, it has really helped our site come along.

    The only question I have is:- Is there a way of displaying the newest images first instead of last?

  30. Byron Bennett July 6, 2009 at 12:14 am #

    Plymouth RC,

    Thanks!

    Sorting is not in there yet…it will be soon!!

    Byron

  31. Vijay August 11, 2009 at 12:39 pm #

    Hi, This is really a great plugin, Thanks Byron.

    I am wondering if there is a way to have “autoadd” enabled based on the category?
    I am researching if there is something like Category Excluder will work 🙂

    really appreciate Byron for such a wondeful plugin.

  32. Byron Bennett August 11, 2009 at 1:03 pm #

    Hi Vijay,

    You’re welcome!

    There isn’t a way to do it by Category yet…but it’s a really good suggestion. I’ll put it on the list…btw, check out the new support site for photosmash at: Smashly.net.

    Byron

  33. Vijay August 11, 2009 at 6:06 pm #

    Really appreciate your response, Byron.

    Thanks for considering to add the feature.

    -Vijay

  34. Sandra Brook August 20, 2009 at 9:07 am #

    Hi Byron,

    This plugin is exactly what I am looking for to implement a photo contest. I am using wordpress MU. I get the plugin installed and everything but as soon as I hit Add Photo, this error appears..”Image upload failed. Your image may have been too large or there may have been another problem. Please reload the page and try again.” I get this before I even attempt to upload an image at all. Just wondering if you have any ideas as to what would cause this. I have set file permissions to 777 but with no luck. Any ideas?

  35. Byron Bennett August 20, 2009 at 9:40 am #

    Hi Sandra,

    There might be a conflict with another plugin. It sounds like something is submitting that form too soon. Are you using WP-Wall by any chance?

    I’d recommend deactivating the other plugins to see if one of them is conflicting. We can see if there is a workaround if you find one.

    BTW, check out the new site PhotoSmash at Smashly.

    Feel free to email me at byron at whypad .com if you want me to take a deeper dive.

    Cheers,
    Byron

  36. Sandra Brook August 20, 2009 at 9:59 am #

    Hi Byron,

    I found it! It is the ‘Popularity Contest’ plugin that is causing that to happen. Not sure why that is.

  37. Sandra Brook August 20, 2009 at 10:01 am #

    However, I still get the same error when I try to upload..so 🙁

  38. Byron Bennett August 20, 2009 at 10:54 am #

    Sandra,
    Send me an email at byron at whypad . com and we can take a deeper dive into the problem.
    BB

  39. SergioC March 16, 2010 at 5:17 pm #

    Thank you for this amazing plugin
    I love it.
    But I do have one small issue, on all my sites I have a wyibia toolbar, and the plugin conflicts with this product. Unfortunatley.
    I was wondering if you were aware of this conflict, and if you had a solution.
    My sites have a heavy photo upload and for me to do this I have disable the toolbar so it will allow me to upload the photos to the gallery.

  40. Byron Bennett March 16, 2010 at 8:00 pm #

    Hi Sergio,

    You’re welcome! I’m glad you like PhotoSmash!

    For supprot question, I have a support forum over at: http://smashly.net/community/

    I’m not familiar with the wyibia toolbar, and didn’t get anything on it when I googled it. What does it do?

    BB

  41. Jaime March 19, 2010 at 12:42 am #

    I’m trying to stop a photosmash gallery from being auto-added to pages. I only want it to be auto-added to all posts.
    I read in the usage instructions on the PS website, that [/ps] tag could be added to stop the gallery from being added to a post (no mention of pages) but I tried using this tag on both posts and pages, but the gallery is still added. Can anyone advise if there is a different tag that I could use… or another way of stopping pages from getting a gallery?

    Thanks.

  42. paul April 12, 2010 at 12:58 pm #

    how can i create youtube video gallery using photomash

Powered by WordPress. Designed by Woo Themes